Конвертация данных. Версия 2.0.24.1. Информация об ошибках

  Код ошибки: 10046390  
  Дата публикации: 29.01.2010 18:01:47  
  Дата последнего изменения: 29.01.2010 0:00:00  
  Описание: Не выполняется поиск ПКО по заданному значению параметра ИмяПКО при выгрузке значения субконто.  
  Способ исправления: В модуле обработки УниверсальныйОбменДаннымиXML в строке 8348
вместо:

ПКОЗначение = НайтиПравило(Субконто);

написать:

ПКОЗначение = НайтиПравило(Субконто, ИмяПКО);
 
  Код ошибки: 10043933  
  Дата публикации: 23.12.2009 17:20:51  
  Дата последнего изменения: 23.12.2009 0:00:00  
  Описание: При загрузке набора записей не отрабатывает флаг "Отказ" в обработчике ПКО "После загрузки". Также не отрабатывает обработчик конвертации "После загрузки объекта" при использовании обработки ОбменДаннымиXML (1.0.4).  
  Код ошибки: 10042824  
  Дата публикации: 16.12.2009 14:58:38  
  Дата последнего изменения: 16.12.2009 0:00:00  
  Описание: Нет возможности загрузить данные из нескольких табличных частей объекта в одну табличную часть документа в базе 7.7.  
  Способ обхода: Создать ПКГС с пустым значением источника и приемником – "ТабличнаяЧасть"
В ПКГС в обработчике "Перед обработкой" надо инициализировать параметр "КоллекцияОбъектов" выгружаемыми данными. Пример кода обработчика:

// выгрузка таблицы Товары
КоллекцияОбъектов = Источник.Товары.Выгрузить();

// выгрузка таблицы Услуги
Для Каждого СтрокаТаблицы ИЗ Источник.Услуги Цикл
ЗаполнитьЗначенияСвойств(КоллекцияОбъектов.Добавить(), СтрокаТаблицы);
КонецЦикла;
 
  Код ошибки: 10023455  
  Дата публикации: 09.12.2009 16:17:36  
  Дата последнего изменения: 09.12.2009 0:00:00  
  Описание: При аварийном завершении чтения данных обработкой "Выгрузка и загрузка данных XML", в некоторых случаях происходит отключение расчета итогов в информационной базе.  
  Способ обхода: Если произошло аварийное завершение, то нужно установить флаг "Отключить использование итогов во время загрузки данных" и нажать на кнопку "Включить итоги"  
  Причина возникновения: Конфигурация источника отличается от конфигурации приемника (конфигурации в которую происходит загрузка). Использование обработки не по назначению.  
  Исправлено в релизе: 2.1.2  
  Код ошибки: 10038111  
  Дата публикации: 15.10.2009 16:29:58  
  Дата последнего изменения: 15.10.2009 0:00:00  
  Описание: На прилагаемом к книге "1С:Предприятие 8: Конвертация данных" компакт-диске неправильно указаны имена файлов информационных баз.  
  Способ обхода: После копирования информационных баз на жесткий диск следует переименовать имена файлов баз на следующее "1Cv8.1CD".  
  Код ошибки: 10029307  
  Дата публикации: 24.07.2009 15:21:36  
  Дата последнего изменения: 24.07.2009 0:00:00  
  Описание: При выгрузке наборов движений документов обработкой "Обмен данными XML" возникает ошибка.  
  Способ исправления: В модуле обработки ОбменДаннымиXML (версия 1.0.3) в функции
ПолучитьНаборДвиженийДокумента() в строке 7783 заменить:

НаборДвиженийДокумента.Отбор.Регистратор.Установить(СсылкаНаДокумент);

на

НаборДвиженийДокумента.Отбор.Регистратор.Установить(СсылкаНаДокумент.Ссылка);
 
  Исправлено в релизе: 2.1.2  
  Код ошибки: 10025885  
  Дата публикации: 19.06.2009 16:05:08  
  Дата последнего изменения: 19.06.2009 0:00:00  
  Описание: Если для правила конвертации объекта установлен признак "Искать объект приемника по внутреннему идентификатору объекта источника", и установлен признак "Продолжить поиск по полям поиска, если по идентификатору объект приемник не найден", то в случае если при загрузке объект будет найден по полям поиска, то значение параметра ОбъектНайден не будет установлено в Истина.  
  Способ обхода: В модуле объекта обработки УниверсальныйОбменДаннымиXML версии
2.0.28 в функции НайтиОбъектПоСсылке() в строке модуля 6189 вместо кода:

Если Не ЗначениеЗаполнено(СсылкаНаОбъект)
И СозданныйОбъект = Неопределено Тогда

Если ПриПереносеОбъектаПоСсылкеУстанавливатьТолькоGIUD Тогда

СсылкаНаОбъект = СтруктураСвойств.Менеджер.ПолучитьСсылку(Новый УникальныйИдентификатор(СвойствоУникальныйИдентификатор));
СсылкаНаОбъектФиктивная = Истина;

ИначеЕсли НЕ НеСоздаватьОбъектЕслиНеНайден Тогда

СсылкаНаОбъект = СоздатьНовыйОбъект(ТипОбъекта, СвойстваПоиска, СозданныйОбъект, НЕ РежимПоискаОсновногоОбъекта, , ИзвестнаяСсылкаУникальногоИдентификатора, НппСсылки,
НППГлобальнойСсылки, ,УстанавливатьУОбъектаВсеСвойстваПоиска);

СвойстваОбъектаМодифицированы = Истина;

КонецЕсли;

ОбъектНайден = Ложь;

КонецЕсли;

вставить код:

Если Не ЗначениеЗаполнено(СсылкаНаОбъект)
И СозданныйОбъект = Неопределено Тогда

Если ПриПереносеОбъектаПоСсылкеУстанавливатьТолькоGIUD Тогда

СсылкаНаОбъект = СтруктураСвойств.Менеджер.ПолучитьСсылку(Новый УникальныйИдентификатор(СвойствоУникальныйИдентификатор));
СсылкаНаОбъектФиктивная = Истина;

ИначеЕсли НЕ НеСоздаватьОбъектЕслиНеНайден Тогда

СсылкаНаОбъект = СоздатьНовыйОбъект(ТипОбъекта, СвойстваПоиска, СозданныйОбъект, НЕ РежимПоискаОсновногоОбъекта, , ИзвестнаяСсылкаУникальногоИдентификатора, НппСсылки,
НППГлобальнойСсылки, ,УстанавливатьУОбъектаВсеСвойстваПоиска);

СвойстваОбъектаМодифицированы = Истина;

КонецЕсли;

ОбъектНайден = Ложь;
Иначе
ОбъектНайден = Истина;

КонецЕсли;
 
  Исправлено в релизе: 2.1.1  
  Код ошибки: 10024408  
  Дата публикации: 01.06.2009 15:18:38  
  Дата последнего изменения: 01.06.2009 0:00:00  
  Описание: При загрузке правил конвертации из файла правил может возникнуть ошибка вида:

Обработка.ЗагрузкаКонвертации(2459)}: Ошибка при вызове метода контекста (НайтиПоНаименованию): В данной транзакции уже происходили ошибки!
НайденныйОбъект = Справочник.НайтиПоНаименованию(Имя, Истина, Родитель, Владелец);
по причине:
В данной транзакции уже происходили ошибки!
 
  Способ воспроизведения: Загрузить правила конвертации для ЗиК-БП  
  Исправлено в релизе: 2.1.2  
  Код ошибки: 10021274  
  Дата публикации: 15.05.2009 17:47:17  
  Дата последнего изменения: 15.05.2009 0:00:00  
  Описание: Параметр обработчика СинхронизироватьПоИдентификатору не является переопределяемым  
  Причина возникновения: Во встроенной справке к обработчику ПКО "Перед выгрузкой" неправильно указано то, что параметр СинхронизироватьПоИдентификатору является переопределяемым  
  Исправлено в релизе: 2.0.28  
  Код ошибки: 10013284  
  Дата публикации: 15.05.2009 17:09:02  
  Дата последнего изменения: 15.05.2009 0:00:00  
  Описание: Не выполняется синхронизация значений (ПКЗ) при изменении источника или приемника ПКО.
Синхронизация значений должна выполнятся по аналогии с синхронизацией ПКС.
 
  Способ воспроизведения: В имеющемся (не новом) правиле конвертации (ПКО) изменить источник или приемник. При этом, если для ПКО были правила конвертации значений (ПКЗ), то из синхронизация с новыми значениями приемника/источника выполнена не будет.  
  Способ обхода: Изменить источник/приемник в ПКЗ вручную после синхронизации ПКС.  
  Исправлено в релизе: 2.0.28  
  Код ошибки: 10011889  
  Дата публикации: 15.05.2009 16:30:44  
  Дата последнего изменения: 15.05.2009 0:00:00  
  Описание: При копировании правила выгрузки способ выборки всегда сбрасывается на "Стандартная обработка".  
  Способ обхода: Вручную изменить способ выборки на требуемый.  
  Исправлено в релизе: 2.0.28  
  Код ошибки: 10008691  
  Дата публикации: 28.11.2008 15:18:32  
  Дата последнего изменения: 28.11.2008 0:00:00  
  Описание: Многократное дублирование записей регистров накопления при выгрузке данных с помощью обработки ВыгрузкаЗагрузкаДанныхXML.  
  Исправлено в релизе: 2.1.2  
  Код ошибки: 10008134  
  Дата публикации: 20.11.2008 21:09:20  
  Дата последнего изменения: 20.11.2008 0:00:00  
  Описание: Не обрабатывается параметр ИдСсылки обработчика правила конвератации объекта "Перед выгрузкой".  
  Исправлено в релизе: 2.0.28  
  Код ошибки: 10007548  
  Дата публикации: 20.11.2008 21:08:35  
  Дата последнего изменения: 20.11.2008 0:00:00  
  Описание: При выгрузке обработкой "Выгрузка загрузка данных XML" набора записей регистров сведений, отбор для которых не установлен, возникает ошибка.  
  Способ воспроизведения: На закладке "Выгрузка" в дереве настройки выгрузки в строке регистра сведений "Варианты встроенных алгоритмов расчета зарплаты" установить флажок.
Нажать кнопку "Выгрузить данные".
 
  Способ исправления: В процедуре ЗаписьЧерезНаборЗаписей() в модуле обработки ВыгрузкаЗагрузкаДанныхXML
строки

// читаем наборы записей с различным составом отбора и записываем их
Пока ВыборкаИзРезультата.Следующий() Цикл

Для Каждого Колонка Из РезультатЗапросаПоЗначениямОтбора.Колонки Цикл
Отбор[Колонка.Имя].Значение = ВыборкаИзРезультата[Колонка.Имя];
Отбор[Колонка.Имя].ВидСравнения = ВидСравнения.Равно;
Отбор[Колонка.Имя].Использование = Истина;
КонецЦикла;

заменить на:

КоличествоПолейОтбора = НаборЗаписей.Отбор.Количество();

// читаем наборы записей с различным составом отбора и записываем их
Пока ВыборкаИзРезультата.Следующий() Цикл

// Отбор устанавливаем для регистров, у которых есть хотя бы один отбор (измерение)
Если КоличествоПолейОтбора <> 0 Тогда

Для Каждого Колонка Из РезультатЗапросаПоЗначениямОтбора.Колонки Цикл
Отбор[Колонка.Имя].Значение = ВыборкаИзРезультата[Колонка.Имя];
Отбор[Колонка.Имя].ВидСравнения = ВидСравнения.Равно;
Отбор[Колонка.Имя].Использование = Истина;
КонецЦикла;

КонецЕсли;
 
  Причина возникновения: Ошибка логики выполнения обработки "Выгрузка Загрузка данных XML".
Выполнение обработки останавливается с ошибкой при попытке выгрузки набора записей непериодического регистра сведений, у которого нет измерений (отбор отсутствует).
Например, в ЗУП регистр сведений "ВариантыВстроенныхАлгоритмовРасчетаЗарплаты".
 
  Исправлено в релизе: 2.0.27  
  Код ошибки: 10007071  
  Дата публикации: 07.11.2008 16:18:53  
  Дата последнего изменения: 07.11.2008 0:00:00  
  Описание: Если в правилах выгрузки табличной части документа устанавить флажок "Выгружать элементы группы через промежуточный файл", то при попытке выгрузить данные из источника возникает сообщение:
Ошибка при выгрузке данных: {ВнешняяОбработка.УниверсальныйОбменДаннымиXML(6618)}: Ошибка при вызове метода контекста (ЗаписатьКонецЭлемента): Не установлен приемник XML
 
  Исправлено в релизе: 2.0.25  
  Код ошибки: 10001838  
  Дата публикации: 31.10.2008 17:20:42  
  Дата последнего изменения: 31.10.2008 0:00:00  
  Описание: При выгрузке данных из конфигурации на платформе версии 7.7 в некоторых случаях формируется неверный ключ выгружаемых данных, из-за чего при повторной выгрузке данных значение выгружается с другим ключом. Эта особенность иногда приводит к возникновению в файле выгрузки узлов такого типа: <Нпп>25</Нпп>.  
  Способ воспроизведения: Например, при переносе записей справочника "НормыРасходов" между однотипными ПУБ (Производство + Услуги + Бухгалтерия) эта особенность приводит к следующим результатам. В справочнике "НормыРасходов" есть реквизит "Элемент" с типом "Справочник" (вид неопределен, но обычно это "Материалы" или "Номенклатура"). В момент выгрузки реквизита, для него будет создан ключ. Допустим выгрузили "материал", внутри него есть реквизит "ОсновнаяЕдиницаИзмерения" содержащий элемент подчиненного справочника, при выгрузке которого будет выгружаться "Владелец" и его ключ не совпадает с ключем "материала".  
  Способ обхода: Для примера, описанного в способе воспроизведения: в коде обработчика "Перед выгрузкой" правила конвертации свойств для реквизита "Владелец" (поле "Перед выгрузкой" закладки "Основная" формы элемента справочника "Правила конвертации свойств") добавить код:

СпрМатер = СоздатьОбъект("Справочник.Материалы");
СпрМатер.НайтиЭлемент(Источник.Элемент);
Значение = СпрМатер.ТекущийЭлемент();

переопределяя выгружаемое значение.
 
  Код ошибки: 10006081  
  Дата публикации: 28.10.2008 15:52:34  
  Дата последнего изменения: 28.10.2008 0:00:00  
  Описание: Правила обмена, содержащие обработчики ПередПолучениемИзмененныхОбъектов и ПриПолученииИнформацииОбУдалении, не могут быть загружены в обработку УниверсальныйОбменДаннымиXML.  
  Причина возникновения: Указанные обработчики не поддерживаются обработкой УниверсальныйОбменДаннымиXML.  
  Исправлено в релизе: 2.0.25  
  Код ошибки: 10001445  
  Дата публикации: 01.10.2008 15:26:05  
  Дата последнего изменения: 01.10.2008 0:00:00  
  Описание: В правиле конвертации объекта (ПКО) отмечены следующие пункты:

- искать объект приемника по внутреннему идентификатору объекта источника
- не создавать новый объект в приемнике, если он не найден

При загрузке возникает ошибка:

Ошибка при загрузке данных: {ВнешняяОбработка.УниверсальныйОбменДаннымиXML(5353)}: Ошибка при вызове метода контекста (ПолучитьОбъект): Элемент не выбран!
 
  Способ исправления: 1. Заменить код процедуры ПолучитьОбъектПоСсылкеИДопИнформации
обработки УниверсальныйОбменДаннымиXML на приведенный ниже:

Функция ПолучитьОбъектПоСсылкеИДопИнформации(СозданныйОбъект, Ссылка)

// если объект создали, то работаем с ним, если нашли - получаем объект
Если СозданныйОбъект <> Неопределено Тогда
Объект = СозданныйОбъект;
Иначе
Если Ссылка.Пустая() Тогда
Объект = Неопределено;
Иначе
Объект = Ссылка.ПолучитьОбъект();
КонецЕсли;
КонецЕсли;

Возврат Объект;

КонецФункции

2. В функции НайтиОбъектПоСсылке обработки
УниверсальныйОбменДаннымиXML после кода:


Если Не ЗначениеЗаполнено(СсылкаНаОбъект)
И ПриПереносеОбъектаПоСсылкеУстанавливатьТолькоGIUD Тогда

СсылкаНаОбъект = СтруктураСвойств.Менеджер.ПолучитьСсылку(Новый УникальныйИдентификатор(СвойствоУникальныйИдентификатор));
ОбъектНайден = Ложь;
СсылкаНаОбъектФиктивная = Истина;

КонецЕсли;

заменить код на:

Если СсылкаНаОбъект <> Неопределено
И СсылкаНаОбъект.Пустая() Тогда

СсылкаНаОбъект = Неопределено;

КонецЕсли;

Если СсылкаНаОбъект <> Неопределено
ИЛИ СозданныйОбъект <> Неопределено Тогда
ДобавитьСсылкуВСписокЗагруженныхОбъектов(НППГлобальнойСсылки, НппСсылки, СсылкаНаОбъект, СсылкаНаОбъектФиктивная);

КонецЕсли;

Возврат СсылкаНаОбъект;
 
  Исправлено в релизе: 2.0.25  
  Код ошибки: 10001444  
  Дата публикации: 01.10.2008 15:25:42  
  Дата последнего изменения: 01.10.2008 0:00:00  
  Описание: Поля, отмеченные для поиска, в некоторых случаях не устанавливаются из-за ошибки в модуле обработки УниверсальныйОбменДаннымиXML.
 
  Способ исправления: В строке 4807 модуля обработки УниверсальныйОбменДаннымиXML
заменить вызов функции ОбработатьУстановкуСвойствПоискаУОбъекта
на следующий:

ОбработатьУстановкуСвойствПоискаУОбъекта(УстанавливатьУОбъектаВсеСвойстваПоиска, ТипОбъекта, СвойстваПоиска,
СвойстваПоискаНеЗамещать, СсылкаНаОбъект, СозданныйОбъект, НЕ РежимПоискаОсновногоОбъекта, СвойстваОбъектаМодифицированы);
 
  Причина возникновения: В вызове функции ОбработатьУстановкуСвойствПоискаУОбъекта в строке 4807 модуля обработки УниверсальныйОбменДаннымиXML пропущен 2-й параметр ТипОбъекта.  
  Исправлено в релизе: 2.0.25